Skip function from Bluetooth device not working properly – Beta 7.52-rc-2 (9162

  • I’m in the beta program for Android, since the last app update the skip functions sent from my Bluetooth headphones (pixel buds a-series) don’t work properly anymore. Skipping forward or back seems to work only occasionally, but usually just leaves you in the same spot, or maybe off by only a second or two (when it should be skipping 30 or 60 seconds). Using the skip controls in the app itself works perfectly fine, I’m only noticing this when using Bluetooth controls.

  • still present on rc-3. Same headphones. I have some other ones I can try in case the issue is device specific?

  • Hi, @joshuapritt and @hdsheena! We have something for you two to try.

    Can you please go to your phone’s Bluetooth Settings and unpair your headphones? Then, please re-pair your headphones again with your phone.

    Can you see if that allows you to skip playback in Pocket Casts again with your headphones? Please let us know how that goes!

  • Just adding on to this thread: I’m on v7.52 (9168) and have also had this issue come up recently. I’ve “forgotten” then re-paired my headphones, and it works for maybe a few taps (forward or backward) before it goes back to the same issue that @joshuapritt explains. I’ve also done the factory reset on the Pixel Buds by holding the little button on the back of the case and experience the same thing.

    It almost appears as if the app is reacting too quickly to the taps and is doing 2 quick “pause/resumes” instead of noticing that a double-tap is about to happen.

  • Thank you for giving that a try! Our team is still looking into this, and we’ve found one other step that resolves this issue.

    Please try updating your Bud’s with the new firmware release from Google: . We’ve had reports that resolves this and are hoping it works for you too.

  • I’ve been emailing with support (slowly) but I’ll also post here for visibility:

    I’ve tried unpairing/repairing and it didn’t resolve the issue. It may be a Pixel Buds A Series-specific issue because I tried a different headset and they worked. However, it’s notable that my Pixel Buds did not have any firmware update that I’m aware of (currently v3.527.0), and they continue to work as expected for other apps. I did upgrade to Android 14 at some point, though I can’t remember if it lined up exactly or not, so that is a possible factor (I’m currently on UP1A.231105.003 on a Pixel 6a).

    When I use Bluetooth controls to try to skip forward or backward, I can see the interface play/pause and also see the seek bar time jump for a split second.

    I just tried uninstalling/reinstalling the app, no luck, and then uninstalled and installed v7.51 and it fixed the issue. After all that, I just re-entered the beta and now have v7.53 rc2, and the issue is back.

  • Not in the beta program, but production, V7.52(9168)

    Using Pixel Buds-A, both buds and case have firmware 3.527.0

    Using Pixel 7, Running Android 14 with the November security update.

    Same problem as described above

    I did a factory reset of the Pixel Buds-A a couple times over the last week to see if that would fix it, and the problem persists.

Reply to Skip function from Bluetooth device not working properly – Beta 7.52-rc-2 (9162